Paystack - Ghana : Telecel system downtime – Incident details

All systems operational

Ghana : Telecel system downtime

Resolved
Partial outage
Started 4 months agoLasted 1 day

Affected

Transactions

Updates
  • Resolved
    Resolved

    This incident has been resolved.

  • Investigating
    Investigating

    Our partner Telecel, is currently having a downtime on their platform, which is affecting mobile money transactions at the moment. As a result, most Telecel transactions are failing. We're currently liaising with them to fix the issues and restore the service. Please bear with us.