Paystack - Issues exporting data from the Dashboard – Incident details

All systems operational

Issues exporting data from the Dashboard

Resolved
Degraded performance
Started 2 months agoLasted 1 day

Affected

Dashboard

Updates
  • Resolved
    Resolved

    As of July 30, 2025 2200H UTC, this should be resolved and all our systems are up-to-date and working as expected. Thank you so much for your patience and apologies for the inconvenience.

  • Update
    Update

    Our team has implemented a solution, the newer systems are still catching up with the latest data. The lag is under 20h now. We expect the issue to be resolved by tomorrow morning.

  • Update
    Update

    Our team has implemented a solution, the newer systems are still catching up with the latest data. The lag has reduced to 48hrs now. We will share more updates on the ETA soon.

  • Identified
    Identified

    You might experience issues in retrieving your most recent data (data from the last 96hrs). Our Engineering team has identified the root of the issue and is implementing a fix. We will share more updates on the ETA soon.