Paystack - Nigeria: Direct Debit Downtime – Incident details

All systems operational

Nigeria: Direct Debit Downtime

Resolved
Partial outage
Started about 1 month agoLasted 7 days

Affected

Transactions

Operational from 10:48 AM to 10:48 AM, Partial outage from 10:48 AM to 12:48 PM

NIGERIA

Operational from 10:48 AM to 10:48 AM, Partial outage from 10:48 AM to 12:48 PM

Direct Debit

Operational from 10:48 AM to 10:48 AM, Partial outage from 10:48 AM to 12:48 PM

Updates
  • Resolved
    Resolved

    The central switch has resolved the issue, and the system is now stable

  • Investigating
    Investigating

    We're currently experiencing a downtime with the Direct Debit channel due to an issue with our processing partner. As a result, attempts to link new bank accounts and charge already linked accounts may fail. We are working with our processing partner to resolve the issue and will share updates as soon as possible.