Paystack - Downtime on Paystack Titan accounts – Incident details

Mobile Money experiencing degraded performance

Downtime on Paystack Titan accounts

Resolved
Major outage
Started 3 days agoLasted 35 minutes

Affected

Transfers

Major outage from 3:28 PM to 4:03 PM

NIGERIA

Major outage from 3:28 PM to 4:03 PM

Bank

Major outage from 3:28 PM to 4:03 PM

Managed Accounts

Major outage from 3:28 PM to 4:03 PM

Updates
  • Resolved
    UTC
    Resolved
    This incident has been resolved.
  • Monitoring
    UTC
    Monitoring
    We implemented a fix and are currently monitoring the result.
  • Investigating
    UTC
    Investigating

    We are seeing an increase in failures for inward transfers to Paystack Titan Pay with Transfer (PwY) accounts as a result of a technical issue. As a result, you may be unable to complete transfers to Paystack Titan accounts.


    We're working to resolving this as quickly as possible and will share an update as soon as possible. We apologize for any inconvenience this might cause.