Paystack - Nigeria: Direct Debit Downtime – Incident details

All systems operational

Nigeria: Direct Debit Downtime

Resolved
Major outage
Started about 1 month agoLasted about 4 hours

Affected

Transactions

Major outage from 11:53 AM to 4:06 PM

NIGERIA

Major outage from 11:53 AM to 4:06 PM

Direct Debit

Major outage from 11:53 AM to 4:06 PM

Updates
  • Resolved
    UTC
    Resolved
    This incident has been resolved.
  • Monitoring
    UTC
    Monitoring

    A fix has been implemented and performance has improved. We are monitoring closely.

  • Identified
    UTC
    Identified

    We are currently experiencing increased failures on the Direct Debit channel as a result of a downtime with our processing partner

    What does this mean for you?

    • Attempts to charge already linked accounts may fail.

    • Attempts to link new bank accounts may also fail.

    We are in active communication with the service provider and will share updates as soon as more information becomes available.

    We apologize for any inconvenience this might cause.