Paystack - Nigeria: Paystack Titan Downtime – Incident details

All systems operational

Nigeria: Paystack Titan Downtime

Resolved
Major outage
Started 1 day agoLasted about 19 hours

Affected

Transactions

Major outage from 9:02 PM to 3:34 PM

NIGERIA

Major outage from 9:02 PM to 3:34 PM

Bank Transfer

Major outage from 9:02 PM to 3:34 PM

Transfers

Major outage from 9:02 PM to 3:34 PM

NIGERIA

Major outage from 9:02 PM to 3:34 PM

Managed Accounts

Major outage from 9:02 PM to 3:34 PM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Monitoring
    Monitoring
    We implemented a fix and are currently monitoring the result.
  • Investigating
    Investigating

    We are currently experiencing a delay in processing Paystack Titan transactions. As a result, transfers to Paystack Titan accounts may take longer than usual to be delivered.

    We are working to resolve this and will share updates.

    We apologize for any inconvenience this might cause.