Scheduled for March 15, 2026 at 12:00 AM – 8:00 AM
Affects
Transactions
Under maintenance from 12:00 AM to 8:00 AM
GHANA
Under maintenance from 12:00 AM to 8:00 AM
Mobile Money
Under maintenance from 12:00 AM to 8:00 AM
Transfers
Under maintenance from 12:00 AM to 8:00 AM
GHANA
Under maintenance from 12:00 AM to 8:00 AM
Mobile Money
Under maintenance from 12:00 AM to 8:00 AM
Updates
Completed
March 15, 2026 at 8:00 AM
Completed
March 15, 2026 at 8:00 AM
Maintenance has completed successfully
In progress
March 15, 2026 at 12:00 AM
In progress
March 15, 2026 at 12:00 AM
Maintenance is now in progress
Planned
March 15, 2026 at 12:00 AM
Planned
March 15, 2026 at 12:00 AM
Our mobile money partner AirtelTigo will undergo a system maintenance from 15th March 2026 00:00 to 15th March 2026 08:00 GMT.
During that time, customers using AirtelTigo to make payments and receive disbursements via Paystack might experience some service disruption.
However, other payment methods such as pay with bank transfer, cards and other mobile money services, as well as disbursements to bank accounts and other mobile money accounts, will not be affected.