Paystack - Degraded Performance on Verve Card Processing – Incident details

Experiencing partially degraded performance

Degraded Performance on Verve Card Processing

Resolved
Degraded performance
Started 2 days agoLasted about 2 hours

Affected

Transactions

Degraded performance from 7:59 AM to 10:12 AM

NIGERIA

Degraded performance from 7:59 AM to 10:12 AM

Cards

Degraded performance from 7:59 AM to 10:12 AM

Updates
  • Resolved
    Resolved

    Verve cards are now processing normally again. We apologize again for any inconvenience this might have caused.

  • Investigating
    Investigating

    We are currently seeing an increased number of failed transactions for Verve cards due to downtime from one of our processing partners.

    As a result, some payments made with Verve cards may fail. Other card types and payment channels are operating normally.

    We are actively working with our partner to resolve the issue and will share updates as soon as more information is available.

    We apologize for the inconvenience and appreciate your patience.