Paystack - Delay in Completing Topups to Titan Trust Bank Accounts – Incident details

All systems operational

Delay in Completing Topups to Titan Trust Bank Accounts

Resolved
Major outage
Started 2 days agoLasted about 22 hours

Affected

Transfers

Operational from 10:43 AM to 10:48 AM, Degraded performance from 10:48 AM to 8:52 AM

NIGERIA

Operational from 10:43 AM to 10:48 AM, Degraded performance from 10:48 AM to 8:52 AM

Managed Accounts

Operational from 10:43 AM to 10:48 AM, Degraded performance from 10:48 AM to 8:52 AM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Identified
    Identified
    We are continuing to work on a fix for this incident.
  • Investigating
    Investigating

    We are currently experiencing a delay in applying Topups to Titan Trust Bank accounts due to a technical issue with the bank.

    We're working with the Titan Trust team to resolve this issue as quickly as possible and will provide an update as soon as it has been resolved.

    In the interim, kindly reach out to support@paystack.com with proof of payment for pending top-ups so we can resolve them.

    We're sorry for any inconvenience this might cause.