Paystack - Kenya: MPESA System Downtime – Incident details

Experiencing partially degraded performance

Kenya: MPESA System Downtime

Resolved
Major outage
Started 2 days agoLasted about 2 hours

Affected

Transactions

Major outage from 10:39 AM to 12:33 PM

KENYA

Major outage from 10:39 AM to 12:33 PM

M-PESA

Major outage from 10:39 AM to 12:33 PM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Investigating
    Investigating

    Our partner, MPESA, is currently having a downtime on their platform, which is affecting mobile money transactions. As a result, most MPESA STK PUSH transactions are failing. However, transactions via Paybill are successful.

    We're currently liaising with them to fix the issues and restore the service.