Paystack - Ghana: MTN System Downtime – Incident details

All systems operational

Ghana: MTN System Downtime

Resolved
Degraded performance
Started about 20 hours agoLasted about 3 hours

Affected

Transactions

Degraded performance from 8:00 PM to 11:15 PM

GHANA

Degraded performance from 8:00 PM to 11:15 PM

Mobile Money

Degraded performance from 8:00 PM to 11:15 PM

Transfers

Degraded performance from 8:00 PM to 11:15 PM

GHANA

Degraded performance from 8:00 PM to 11:15 PM

Mobile Money

Degraded performance from 8:00 PM to 11:15 PM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Investigating
    Investigating

    We are currently experiencing an issue with MTN Mobile Money transactions due to downtime on MTN’s platform. This is causing most MTN Mobile Money payments to fail.

    Our team is in active communication with MTN, and we are working closely with them to restore full service as quickly as possible. We’ll share further updates as soon as they are available.