Paystack - Paystack Direct Debit & Vault Verification Downtime – Incident details

All systems operational

Paystack Direct Debit & Vault Verification Downtime

Resolved
Degraded performance
Started 5 months agoLasted 1 day

Affected

Transactions

Degraded performance from 10:26 AM to 5:32 PM

NIGERIA

Degraded performance from 10:26 AM to 5:32 PM

Direct Debit

Degraded performance from 10:26 AM to 5:32 PM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Monitoring
    Monitoring

    We are currently experiencing an issue with our Verification service for Paystack Direct Debit and Paystack Vault on Checkout that impacts customers' ability to link their bank accounts.

    We are investigating the issue and are working to fix it. We apologize for any inconvenience that this might cause.