Paystack - Refund Processing Delay – Incident details

Cards experiencing degraded performance

Refund Processing Delay

Resolved
Partial outage 30 %
Started 4 months agoLasted about 4 hours

Affected

Platform & Infrastructure

Partial outage from 3:06 PM to 6:59 PM

Refunds

Partial outage from 3:06 PM to 6:59 PM

Transactions

Degraded performance from 3:06 PM to 6:59 PM

NIGERIA

Degraded performance from 3:06 PM to 6:59 PM

Bank Transfer

Degraded performance from 3:06 PM to 6:59 PM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Investigating
    Investigating

    We are currently experiencing a system issue that is temporarily preventing us from fully processing refunds.We understand this may cause inconvenience and we sincerely apologize.Our technical team is aware of the issue and is working with the highest priority to restore full refund functionality as quickly as possible.