Paystack - Nigeria: Downtime on Inward Transfers to Paystack Titan accounts – Incident details

All systems operational

Nigeria: Downtime on Inward Transfers to Paystack Titan accounts

Resolved
Major outage
Started 4 days agoLasted about 1 hour

Affected

Transactions

Major outage from 11:51 AM to 1:01 PM

NIGERIA

Major outage from 11:51 AM to 1:01 PM

Bank Transfer

Major outage from 11:51 AM to 1:01 PM

Updates
  • Resolved
    Resolved
    This incident has been resolved.
  • Investigating
    Investigating

    We are seeing an increase in failures for inward transfers to Paystack Titan Pay with Transfer (PwY) accounts as a result of a technical issue with our processing partner. As a result, you may be unable to complete transfers to Paystack Titan accounts.

    We're working with our processing partner to resolve this as quickly as possible and will share an update as soon as possible. We apologize for any inconvenience this might cause.