Paystack - South Africa: Increased 3DS failures for Capitec-issued cards – Incident details

QR under maintenance

South Africa: Increased 3DS failures for Capitec-issued cards

Resolved
Degraded performance
Started about 1 month agoLasted about 1 hour

Affected

Transactions

Updates
  • Resolved
    Resolved

    This incident has been resolved.

  • Monitoring
    Monitoring

    Success rates have been stable since 22:00 SAST. We will continue to monitor.

  • Investigating
    Investigating

    We've seen an increased number of failures for 3DS transactions using Capitec-issued cards. It has been escalated to our 3rd-party partners.