Paystack - Nigeria: United Bank for Africa (UBA) Downtime – Incident details

QR under maintenance

Nigeria: United Bank for Africa (UBA) Downtime

Resolved
Degraded performance
Started 17 days agoLasted about 3 hours

Affected

Transactions

Updates
  • Resolved
    Resolved

    This incident has been resolved.

  • Investigating
    Investigating

    The scheduled maintenance by UBA is still ongoing. As a result, transactions on UBA-issued cards may continue to fail. We’re in active contact with the bank and will provide updates as soon as we receive feedback. We apologize for the inconvenience and appreciate your patience.